Ticket #40866

TeraTerm 'disconnect' command unlinks MACRO (From Forum Message #86029)

오픈 날짜: 2020-10-19 20:55 마지막 업데이트: 2020-11-21 00:16

Reporter:
소유자:
(None)
Status:
Open
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Works For Me
File:
3
Vote
Score: 1
100.0% (1/1)
0.0% (0/1)

Details

From Forum Help [#86029]

[forum: 86029]

I use a MACRO to connect to usb com ports. I have two issues with this:

A) If the com port i specify to connect with connect '/C=...' UPPON MACRO STARTUP does not exist, the .ttl script will terminate and close... (why? i dont want that). Alternatively, is there a way to list all available usb com port devices and THEN try to connect to each of those?

B) After connecting to a COM port, using the command 'disconnect 0' or 'disconnect 1', the MACRO closes/terminates. (How can i terminate the connection to the host (COM port) only, without terminating Teraterm?)

//=====================================================================

;Code that disconnects my macro when trying to connect to a port that does not exist, UPPON MACRO STARTUP:

;both com-ports 3 and 6 are available for connection. The others are not.

timeout = 4

connect '/C=1' ;this disconnects my MACRO. I dont want it to disconnect my macro.

wait 'never'

dispstr 'END'

//==============================================================

;Code that closes my link to MACRO when using the 'disconnect command:

;both comport 3 and 6 are available for connection. The others are not.

timeout = 4

connect '/C=3' ;this connects as normal.

wait 'never'

disconnect 0 ;this closes my TeraTerm (I dont want it to close my teraTerm

wait 'never'

dispstr 'TT is still active'

wait 'never'

dispstr 'END'

Ticket History (3/11 Histories)

2020-10-19 20:55 Updated by: basilisvirus
  • New Ticket "TeraTerm 'disconnect' command closes TeraTerm window (From Forum Message #86029)" created
2020-10-19 21:38 Updated by: nmaya
댓글 올리기

When the connection type is TCP/IP, "Auto window close" setting affects close or not close Tera Term window.

But when the connection type is Serial, Tera Term is not closed. It is a specification.

(A) 'connect' macro command do 2 actions.

It is written in command help. https://ttssh2.osdn.jp/manual/4/en/macro/command/connect.html

  • runs Tera Term with <command line parameters>
  • links it to MACRO

After connect '/C=...' failed, Tera Term is not connected to serial port, but Tera Term is alive. The link between MACRO and Tera Term is alive too.

To close linked Tera Term, call 'closett' macro command.

Or you can reuse linked Tera Term. To connect different remote host (serial port), call 'connect' macro command.

(B) Not reproduced in my environment.

'disconnect' macro command does not close Tera Term window.

Thanks,

2020-10-19 23:14 Updated by: basilisvirus
  • Details Updated
  • Summary Updated
댓글 올리기
(This comment has been deleted)
2020-10-19 23:15 Updated by: basilisvirus
  • Details Updated
2020-10-19 23:17 Updated by: basilisvirus
댓글 올리기

Thank you, i re-stated my ticked Details. Can you check it again? I am more specific not to the problem. I am also attaching the .INI file for you to make a better test.

2020-10-19 23:18 Updated by: basilisvirus
  • Details Updated
2020-10-20 00:17 Updated by: nmaya
댓글 올리기

My test script behaves as expected in my env.

In my env with your TERATERM.INI, my script behaves as expected too.

What about in your env?

2020-11-21 00:16 Updated by: nmaya
  • Resolution Update from None to Works For Me
  • Severity Update from 9 - Highest to 5 - Medium
  • Priority Update from 9 - Highest to 5 - Medium

Attachment File List

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login